re = /(?:\b(s)(?=tupid\b)|(?!\A)\G)\pL/
str = 'hello, i think you are not intelligent, you are actually dumb and stupid.'
subst = '$1-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result