using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:font-family:|https?:\/\/)[^\s\'"";}]*(*SKIP)(*FAIL)(media)";
string input = @"#mediator .media
amedias media lorem ipsumedia ar
{ el : ""https://twitter.com/intent/medias/"" } Amedia
.element{ font-family: media} .media";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}