// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:font-family:|https?:\/\/)[^\s\'";}]*(*SKIP)(*FAIL)(media)"#).unwrap();
let string = "#mediator .media
amedias media lorem ipsumedia ar
{ el : \"https://twitter.com/intent/medias/\" } Amedia
.element{ font-family: media} .media";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}