$re = '/(?:font-family:|https?:\/\/)[^\s\'";}]*(*SKIP)(*FAIL)(media)/m';
$str = '#mediator .media
amedias media lorem ipsumedia ar
{ el : "https://twitter.com/intent/medias/" } Amedia
.element{ font-family: media} .media';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);