const regex = /(?:font-family:|https?:\/\/)[^\s\'";}]*(*SKIP)(*FAIL)(media)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:font-family:|https?:\\\/\\\/)[^\\s\\\'";}]*(*SKIP)(*FAIL)(media)', 'gm')
const str = `#mediator .media
amedias media lorem ipsumedia ar
{ el : "https://twitter.com/intent/medias/" } Amedia
.element{ font-family: media} .media`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}