re = /(?:font-family:|https?:\/\/)[^\s\'";}]*(*SKIP)(*FAIL)(media)/m
str = '#mediator .media
amedias media lorem ipsumedia ar
{ el : "https://twitter.com/intent/medias/" } Amedia
.element{ font-family: media} .media'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end