const regex = /Владелец: (\w+_\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Владелец: (\\w+_\\w+)', 'gm')
const str = `style="top:813.166px;left:830.066px;background:url(/images/business_0.gif)" title="<div class='text-center'>Амуниция/Тир<br><br>Владелец: Richard_Universe</div>" data-toggle="tooltip" data-html="true"></div><div class="map-icon business-state-0 business-not-sale" style="top:558.291px;left:1013.365px;background:url(/images/business_0.gif)" title="<div class='text-center'>Амуниция/Тир<br><br>Владелец: Brake_Blame</div>" data-toggle="tooltip" data-html="true"></div><div class="map-icon business-state-0 business-not-sale" style="top:603.893px;left:616.15px;background:url(/images/business_0.gif)" title="<div class='text-center'>Амуниция/Тир<br><br>Владелец: Queens_Nakamura</div>" data-toggle="tooltip" data-html="true"></div><div class="map-icon business-state-1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}