import Foundation
let pattern = #"Владелец: (\w+_\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
style="top:813.166px;left:830.066px;background:url(/images/business_0.gif)" title="<div class='text-center'>Амуниция/Тир<br><br>Владелец: Richard_Universe</div>" data-toggle="tooltip" data-html="true"></div><div class="map-icon business-state-0 business-not-sale" style="top:558.291px;left:1013.365px;background:url(/images/business_0.gif)" title="<div class='text-center'>Амуниция/Тир<br><br>Владелец: Brake_Blame</div>" data-toggle="tooltip" data-html="true"></div><div class="map-icon business-state-0 business-not-sale" style="top:603.893px;left:616.15px;background:url(/images/business_0.gif)" title="<div class='text-center'>Амуниция/Тир<br><br>Владелец: Queens_Nakamura</div>" data-toggle="tooltip" data-html="true"></div><div class="map-icon business-state-1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)