import re
regex = re.compile(r"Владелец: (\w+_\w+)", flags=re.MULTILINE)
test_str = ("style=\"top:813.166px;left:830.066px;background:url(/images/business_0.gif)\" title=\"<div class='text-center'>Амуниция/Тир<br><br>Владелец: Richard_Universe</div>\" data-toggle=\"tooltip\" data-html=\"true\"></div><div class=\"map-icon business-state-0 business-not-sale\" style=\"top:558.291px;left:1013.365px;background:url(/images/business_0.gif)\" title=\"<div class='text-center'>Амуниция/Тир<br><br>Владелец: Brake_Blame</div>\" data-toggle=\"tooltip\" data-html=\"true\"></div><div class=\"map-icon business-state-0 business-not-sale\" style=\"top:603.893px;left:616.15px;background:url(/images/business_0.gif)\" title=\"<div class='text-center'>Амуниция/Тир<br><br>Владелец: Queens_Nakamura</div>\" data-toggle=\"tooltip\" data-html=\"true\"></div><div class=\"map-icon business-state-1\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")