// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Владелец: (\w+_\w+)").unwrap();
let string = "style=\"top:813.166px;left:830.066px;background:url(/images/business_0.gif)\" title=\"<div class='text-center'>Амуниция/Тир<br><br>Владелец: Richard_Universe</div>\" data-toggle=\"tooltip\" data-html=\"true\"></div><div class=\"map-icon business-state-0 business-not-sale\" style=\"top:558.291px;left:1013.365px;background:url(/images/business_0.gif)\" title=\"<div class='text-center'>Амуниция/Тир<br><br>Владелец: Brake_Blame</div>\" data-toggle=\"tooltip\" data-html=\"true\"></div><div class=\"map-icon business-state-0 business-not-sale\" style=\"top:603.893px;left:616.15px;background:url(/images/business_0.gif)\" title=\"<div class='text-center'>Амуниция/Тир<br><br>Владелец: Queens_Nakamura</div>\" data-toggle=\"tooltip\" data-html=\"true\"></div><div class=\"map-icon business-state-1
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}