using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)(2\[(.+?)\])(.*)";
string substitution = @"$2 ";
string input = @"0[0]1[100]2[fellow_starmadian]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}