use strict;
my $str = '0[0]1[100]2[fellow_starmadian]';
my $regex = qr/(.*)(2\[(.+?)\])(.*)/p;
my $subst = '$2 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";