$re = '/(.*)(2\[(.+?)\])(.*)/';
$str = '0[0]1[100]2[fellow_starmadian]';
$subst = "$2 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;