// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)(2\[(.+?)\])(.*)").unwrap();
let string = "0[0]1[100]2[fellow_starmadian]";
let substitution = "$2 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}