#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE) # regex definitions" & @CRLF & _
" (?P<string>[a-zA-Z0-9]+)" & @CRLF & _
" (?P<value>\s*(?:(?&string)|(?&array)|(?&object))\s*)" & @CRLF & _
" (?P<array>\s*\[\s*(?&value)\s*(?:\s*,\s*(?&value)\s*)*\])" & @CRLF & _
" (?P<pair>(?&string)\s*:\s*(?&value))" & @CRLF & _
" (?P<object>\{\s*(?&pair)\s*(?:\s*,\s*(?&pair)\s*)*\})" & @CRLF & _
")" & @CRLF & _
"(?&object)"
Local $sString = " {" & @CRLF & _
" foo : bar," & @CRLF & _
" baz : [aa, bb, ccc]," & @CRLF & _
" 123 : 123," & @CRLF & _
" obj : { foo : bar}" & @CRLF & _
"}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")