import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?(DEFINE) # regex definitions\n"
+ " (?P<string>[a-zA-Z0-9]+)\n"
+ " (?P<value>\\s*(?:(?&string)|(?&array)|(?&object))\\s*)\n"
+ " (?P<array>\\s*\\[\\s*(?&value)\\s*(?:\\s*,\\s*(?&value)\\s*)*\\])\n"
+ " (?P<pair>(?&string)\\s*:\\s*(?&value))\n"
+ " (?P<object>\\{\\s*(?&pair)\\s*(?:\\s*,\\s*(?&pair)\\s*)*\\})\n"
+ ")\n"
+ "(?&object)";
final String string = " {\n"
+ " foo : bar,\n"
+ " baz : [aa, bb, ccc],\n"
+ " 123 : 123,\n"
+ " obj : { foo : bar}\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}