re = /(?(DEFINE) # regex definitions
(?P<string>[a-zA-Z0-9]+)
(?P<value>\s*(?:(?&string)|(?&array)|(?&object))\s*)
(?P<array>\s*\[\s*(?&value)\s*(?:\s*,\s*(?&value)\s*)*\])
(?P<pair>(?&string)\s*:\s*(?&value))
(?P<object>\{\s*(?&pair)\s*(?:\s*,\s*(?&pair)\s*)*\})
)
(?&object)/mx
str = ' {
foo : bar,
baz : [aa, bb, ccc],
123 : 123,
obj : { foo : bar}
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end