const regex = /(?(DEFINE) # regex definitions
(?P<string>[a-zA-Z0-9]+)
(?P<value>\s*(?:(?&string)|(?&array)|(?&object))\s*)
(?P<array>\s*\[\s*(?&value)\s*(?:\s*,\s*(?&value)\s*)*\])
(?P<pair>(?&string)\s*:\s*(?&value))
(?P<object>\{\s*(?&pair)\s*(?:\s*,\s*(?&pair)\s*)*\})
)
(?&object)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE) # regex definitions
(?P<string>[a-zA-Z0-9]+)
(?P<value>\\s*(?:(?&string)|(?&array)|(?&object))\\s*)
(?P<array>\\s*\\[\\s*(?&value)\\s*(?:\\s*,\\s*(?&value)\\s*)*\\])
(?P<pair>(?&string)\\s*:\\s*(?&value))
(?P<object>\\{\\s*(?&pair)\\s*(?:\\s*,\\s*(?&pair)\\s*)*\\})
)
(?&object)', 'gm')
const str = ` {
foo : bar,
baz : [aa, bb, ccc],
123 : 123,
obj : { foo : bar}
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}