use strict;
my $str = ' {
foo : bar,
baz : [aa, bb, ccc],
123 : 123,
obj : { foo : bar}
}
';
my $regex = qr/(?(DEFINE) # regex definitions
(?P<string>[a-zA-Z0-9]+)
(?P<value>\s*(?:(?&string)|(?&array)|(?&object))\s*)
(?P<array>\s*\[\s*(?&value)\s*(?:\s*,\s*(?&value)\s*)*\])
(?P<pair>(?&string)\s*:\s*(?&value))
(?P<object>\{\s*(?&pair)\s*(?:\s*,\s*(?&pair)\s*)*\})
)
(?&object)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}