package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?(DEFINE) # regex definitions
(?P<string>[a-zA-Z0-9]+)
(?P<value>\s*(?:(?&string)|(?&array)|(?&object))\s*)
(?P<array>\s*\[\s*(?&value)\s*(?:\s*,\s*(?&value)\s*)*\])
(?P<pair>(?&string)\s*:\s*(?&value))
(?P<object>\{\s*(?&pair)\s*(?:\s*,\s*(?&pair)\s*)*\})
)
(?&object)`)
var str = ` {
foo : bar,
baz : [aa, bb, ccc],
123 : 123,
obj : { foo : bar}
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}