# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?(DEFINE) # regex definitions
(?P<string>[a-zA-Z0-9]+)
(?P<value>\s*(?:(?&string)|(?&array)|(?&object))\s*)
(?P<array>\s*\[\s*(?&value)\s*(?:\s*,\s*(?&value)\s*)*\])
(?P<pair>(?&string)\s*:\s*(?&value))
(?P<object>\{\s*(?&pair)\s*(?:\s*,\s*(?&pair)\s*)*\})
)
(?&object)
"""
test_str = (" {\n"
" foo : bar,\n"
" baz : [aa, bb, ccc],\n"
" 123 : 123,\n"
" obj : { foo : bar}\n"
"}\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.