# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^[\w\h]+(?:, [\w\h]+)+$//gm;t' <<< "cat dog duck
cat, dog, duck
cat dog, cat dog duck, cat dog duck parrot"