import re
regex = re.compile(r"^[\w\h]+(?:, [\w\h]+)+$", flags=re.MULTILINE)
test_str = ("cat dog duck\n"
"cat, dog, duck\n"
"cat dog, cat dog duck, cat dog duck parrot")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)