use strict;
my $str = 'cat dog duck
cat, dog, duck
cat dog, cat dog duck, cat dog duck parrot';
my $regex = qr/^[\w\h]+(?:, [\w\h]+)+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";