// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\w\h]+(?:, [\w\h]+)+$").unwrap();
let string = "cat dog duck
cat, dog, duck
cat dog, cat dog duck, cat dog duck parrot";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}