$re = '/^[\w\h]+(?:, [\w\h]+)+$/m';
$str = 'cat dog duck
cat, dog, duck
cat dog, cat dog duck, cat dog duck parrot';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;