re = /^[\w\h]+(?:, [\w\h]+)+$/m
str = 'cat dog duck
cat, dog, duck
cat dog, cat dog duck, cat dog duck parrot'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result