import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[example\\.com\\].*(\\[(?:(?!example\\.com).)*?\\])";
final String string = "[example.com]0.100.251.10.100.251.200.251.3[example.com]\n"
+ "10.100.251.22\n"
+ "10.100.251.3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}