use strict;
my $str = '[example.com]0.100.251.10.100.251.200.251.3[example.com]
10.100.251.22
10.100.251.3';
my $regex = qr/^\[example\.com\].*(\[(?:(?!example\.com).)*?\])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}