import re
regex = re.compile(r"^\[example\.com\].*(\[(?:(?!example\.com).)*?\])")
test_str = ("[example.com]0.100.251.10.100.251.200.251.3[example.com]\n"
"10.100.251.22\n"
"10.100.251.3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")