$re = '/^\[example\.com\].*(\[(?:(?!example\.com).)*?\])/';
$str = '[example.com]0.100.251.10.100.251.200.251.3[example.com]
10.100.251.22
10.100.251.3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);