re = /^\[example\.com\].*(\[(?:(?!example\.com).)*?\])/
str = '[example.com]0.100.251.10.100.251.200.251.3[example.com]
10.100.251.22
10.100.251.3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end