const regex = /^\[example\.com\].*(\[(?:(?!example\.com).)*?\])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[example\\.com\\].*(\\[(?:(?!example\\.com).)*?\\])', 'g')
const str = `[example.com]0.100.251.10.100.251.200.251.3[example.com]
10.100.251.22
10.100.251.3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}