#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b(APP\d{1,5})\w*|\w+\s*"
Local $sString = "APP00001Was APP00002TEST APP00003Blah blah APP00004 Apple APP11112OrANGE APP" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)