use strict;
my $str = 'APP00001Was APP00002TEST APP00003Blah blah APP00004 Apple APP11112OrANGE APP
';
my $regex = qr/\b(APP\d{1,5})\w*|\w+\s*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";