$re = '/\b(APP\d{1,5})\w*|\w+\s*/m';
$str = 'APP00001Was APP00002TEST APP00003Blah blah APP00004 Apple APP11112OrANGE APP
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;