import re
regex = re.compile(r"\b(APP\d{1,5})\w*|\w+\s*", flags=re.MULTILINE)
test_str = ("APP00001Was APP00002TEST APP00003Blah blah APP00004 Apple APP11112OrANGE APP\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)