re = /\b(APP\d{1,5})\w*|\w+\s*/m
str = 'APP00001Was APP00002TEST APP00003Blah blah APP00004 Apple APP11112OrANGE APP
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result