import Foundation
let pattern = #"\b(APP\d{1,5})\w*|\w+\s*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
APP00001Was APP00002TEST APP00003Blah blah APP00004 Apple APP11112OrANGE APP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)