#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^([a-z][a-z_]*)(/([A-Z][a-z_]*)){,1}$)|(^[A-Z][a-z_]*$)"
Local $sString = "hallo" & @CRLF & _
"hallo_x" & @CRLF & _
"Hallo" & @CRLF & _
"Hallo_x" & @CRLF & _
"hallo/Welt" & @CRLF & _
"hallo_x/Welt" & @CRLF & _
"hallo/Welt_y" & @CRLF & _
"hallo_x/Welt_y" & @CRLF & _
"" & @CRLF & _
"hallo_X" & @CRLF & _
"hallo/welt" & @CRLF & _
"hallO/Welt" & @CRLF & _
"hallo/WelT" & @CRLF & _
"Hallo/Welt" & @CRLF & _
"hallo_x/Welt_Y" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")