$re = '/(^([a-z][a-z_]*)(/([A-Z][a-z_]*)){,1}$)|(^[A-Z][a-z_]*$)/m';
$str = 'hallo
hallo_x
Hallo
Hallo_x
hallo/Welt
hallo_x/Welt
hallo/Welt_y
hallo_x/Welt_y
hallo_X
hallo/welt
hallO/Welt
hallo/WelT
Hallo/Welt
hallo_x/Welt_Y
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);