const regex = new RegExp('(^([a-z][a-z_]*)(/([A-Z][a-z_]*)){,1}$)|(^[A-Z][a-z_]*$)', 'mg')
const str = `hallo
hallo_x
Hallo
Hallo_x
hallo/Welt
hallo_x/Welt
hallo/Welt_y
hallo_x/Welt_y
hallo_X
hallo/welt
hallO/Welt
hallo/WelT
Hallo/Welt
hallo_x/Welt_Y
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}