import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^([a-z][a-z_]*)(/([A-Z][a-z_]*))\\{,1\\}$)|(^[A-Z][a-z_]*$)";
final String string = "hallo\n"
+ "hallo_x\n"
+ "Hallo\n"
+ "Hallo_x\n"
+ "hallo/Welt\n"
+ "hallo_x/Welt\n"
+ "hallo/Welt_y\n"
+ "hallo_x/Welt_y\n\n"
+ "hallo_X\n"
+ "hallo/welt\n"
+ "hallO/Welt\n"
+ "hallo/WelT\n"
+ "Hallo/Welt\n"
+ "hallo_x/Welt_Y\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}