use strict;
my $str = 'hallo
hallo_x
Hallo
Hallo_x
hallo/Welt
hallo_x/Welt
hallo/Welt_y
hallo_x/Welt_y
hallo_X
hallo/welt
hallO/Welt
hallo/WelT
Hallo/Welt
hallo_x/Welt_Y
';
my $regex = qr/(^([a-z][a-z_]*)(/([A-Z][a-z_]*)){,1}$)|(^[A-Z][a-z_]*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}