package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^([a-z][a-z_]*)(/([A-Z][a-z_]*)){,1}$)|(^[A-Z][a-z_]*$)`)
var str = `hallo
hallo_x
Hallo
Hallo_x
hallo/Welt
hallo_x/Welt
hallo/Welt_y
hallo_x/Welt_y
hallo_X
hallo/welt
hallO/Welt
hallo/WelT
Hallo/Welt
hallo_x/Welt_Y
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}