using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.+?)className='\s*(.+?)\s*'>";
string substitution = @"<$1className={styles.$2}>";
string input = @"<div className='random_class_name'></div>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}