const regex = /<(.+?)className='\s*(.+?)\s*'>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(.+?)className=\'\\s*(.+?)\\s*\'>', 'gm')
const str = `<div className='random_class_name'></div>`;
const subst = `<$1className={styles.$2}>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);