import re
regex = re.compile(r"<(.+?)className='\s*(.+?)\s*'>", flags=re.MULTILINE)
test_str = "<div className='random_class_name'></div>"
subst = "<$1className={styles.$2}>"
result = regex.sub(subst, test_str)
if result:
print(result)