re = /<(.+?)className='\s*(.+?)\s*'>/m
str = '<div className=\'random_class_name\'></div>'
subst = '<$1className={styles.$2}>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result