$re = '/<(.+?)className=\'\s*(.+?)\s*\'>/m';
$str = '<div className=\'random_class_name\'></div>';
$subst = "<$1className={styles.$2}>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;